Contribute  :  Calendar  :  Advanced Search  :  Site Statistics  :  Directory  :  Files to download  :  Links for developers  :  Privacy policy  :  Web Resources  :  Polls  
    MacOSX Guru Site Information, tips and tricks, FAQ for Mac OS X developers    
 Welcome to MacOSX Guru Site
 Sunday, August 31 2014 @ 05:22 AM BST

Not suitable image found when executing osascript ?

   
OS X FAQIf you got some "verbose" messages like "Error loading /Library/ScriptingAdditions … no suitable image found." when executing osascript when within your bash scripts… here is a solution…

You have this kind of message:

Error loading /Library/ScriptingAdditions/SOME_EXTENSION_NAME.osax/Contents/MacOS/SOME_EXTENSION_NAME:  dlopen(/Library/ScriptingAdditions/SOME_EXTENSION_NAME.osax/Contents/MacOS/SOME_EXTENSION_NAME, 262): no suitable image found.
because your ScritpingAdditions folder contains some 32-bits only OSAX when SnowLeopard expects 64-bits one…

A quick solution is to add "arch -i386" in front of your osascript invocations in your Shell scripts, example:

arch -i386 osascript -e 'tell application "someAppl" to quit' 
 

What's Related

Story Options

Not suitable image found when executing osascript ? | 0 comments | Create New Account
The following comments are owned by whomever posted them. This site is not responsible for what they say.
 Copyright © 2014 MacOSX Guru Site
 All trademarks and copyrights on this page are owned by their respective owners.
Powered By Geeklog 
Created this page in 0.06 seconds